Is Rogan WordPress 5.0 compatible and GDPR ready?

Viewed: 24
Follow
( 0 Followers )
X

Follow

E-mail : *

Yes, SaasLand is compatible with WordPress 5.0 and higher versions.